Browser out of date

  • 4
  • Problem
  • Updated 2 days ago
2 users in my organization are experiencing this issue with the outlook add-in.
Sharefile is greyed out - if you click on the icon for options, a window pops up and says "Your browser is out of date"
All users are on Windows 10 1511, regularly patched.
I push out Sharefile using PDQ deploy with a powershell script that adds in all the necessary information for logging in without user intervention.  This is the user version.
The users can connect to sharefile via a web browser.  They have IE 11 and Chrome on their desktops.
All other users in my organization have this add-in working flawlessly.  I have no idea what is causing this.
I have changed the default browsers around to see if that would do anything - but no
I have started outlook in safe mode
I have repaired outlook
No dice.
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
  • Unhappy

Posted 1 year ago

  • 4
Photo of Sebastian -

Sebastian -

  • 8 Posts
  • 1 Reply Like

Frist close Outlook and delete all files form C:\Users\username\AppData\Roaming\ShareFile\Outlook (there should be log and config files and possibly a Temp folder please delete them).

 

Then from “Regedit” go to > HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION\ OUTLOOK.EXE REG_DWORD = Value 2af8

 

And add this 

Name: OUTLOOK.exe

Type: REG_DWORD

Value: 2af8
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
It's still a no go :(
Photo of Kevin Glenn

Kevin Glenn, Senior Technical Support Engineer

  • 133 Posts
  • 12 Reply Likes
Hi Renato,

When you added the registry key, was it updated on the app server itself or just the end users machine?

-Kevin Glenn
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
I'm slightly confused about the app server part.
The registry edit I made was done on the end users machine.  

When I first drilled down to: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

There was already a DWORD value set on outlook.exe for 0x2711

So I set it instead of creating, since it already exists:
Set-ItemProperty -path "HKLM:\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION" -name "Outlook.exe" -Value 0x2af8

a quick verify showed me it changed:

reg.exe query "HKLM\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION"
OUTLOOK.EXE    REG_DWORD    0x2af8

This was all done remotely.
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
I should add - on my machine - which also has the outlook plug-in (fully functional)
my registry keys are set at  0x2711 for outlook.exe.
So maybe this could be something else?
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
this is an exerpt from the log.txt in appdata:
2017-09-13T 13:18:47|INFO|Startup!
2017-09-13T 13:18:47|INFO|Windows version Windows10 64-bit  (Microsoft Windows NT 10.0.10586.0)
2017-09-13T 13:18:47|INFO|.NET Framework CLR version 4.0.30319.42000
2017-09-13T 13:18:47|INFO|.NET Framework Version462
2017-09-13T 13:18:47|INFO|Outlook version Outlook 2016 32-bit (16.0.0.8326)
2017-09-13T 13:18:47|INFO|Plugin version 4.4.1252.2
2017-09-13T 13:18:47|INFO|Current UI culture en-US
2017-09-13T 13:18:47|INFO|Addin not configured, disabling
2017-09-13T 13:18:47|INFO|Disabling Plug-in
2017-09-13T 13:18:47|INFO|Stopping upload loop timer
2017-09-13T 13:18:47|INFO|[UpdateService] Initialized, using appCastUrl=https://www.sf-cdn.net/downloads/outlookplugin/updates2.xml
2017-09-13T 13:18:47|INFO|[UpdateService] Stopping AutoUpdate loop.
2017-09-13T 13:18:47|INFO|[InspectorService] Starting.
2017-09-13T 13:18:47|INFO|[ExplorerService] Starting.
2017-09-13T 13:19:37|ERROR|AUTH: Token is Empty
2017-09-13T 13:19:37|ERROR|AUTH FAILED
System.Exception: Exception of type 'System.Exception' was thrown.
   at Malone.PluginContext.GetNewToken(Boolean baseOnPreviousToken)
   at Malone.PluginContext.<ValidateTokenAsync>d__65.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Malone.PluginContext.<AuthenticateAsync>d__64.MoveNext()
2017-09-13T 13:19:37|INFO|Disabling Plug-in
2017-09-13T 13:19:37|INFO|Stopping upload loop timer
2017-09-13T 13:19:37|INFO|[UpdateService] Stopping AutoUpdate loop. 
(Edited)
Photo of Leo

Leo, Official Rep

  • 382 Posts
  • 25 Reply Likes
Hey Renato,

The plugin has to use Internet Explorer to authenticate, so changing the default browser does nothing.  However, on the computers having problems, you mentioned they can log in to the website fine.  Was that through (subdomain).sharefile.com or was it through secure.sharefile.com (or both)?  Is it with SSO?

-Leo
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
Hey Leo,
It is through [mysubdomain].sharefile.com, and with SSO.  That was the information that was given to me by my IT director.  Everyone logs in through that link via a web browser.

This is the script I run on my deployment server after an install

New-Item -path HKCU:\SOFTWARE\Citrix\ShareFile -Name SSO -Force
$regpath = "HKCU:\SOFTWARE\Citrix\ShareFile\SSO"
New-ItemProperty -Path $regpath -name "Method" -value "saml-integrated" -PropertyType "string"
New-ItemProperty -Path $regpath -Name "UserConfigurable" -Value 0 -PropertyType "DWORD"
New-ItemProperty -Path $regpath -Name "Subdomain" -Value "mycompaniesname" -PropertyType "string"
New-ItemProperty -Path $regpath -Name "APiCP" -Value "sf-api.com" -PropertyType "string"

Again, this method has worked on over 20 machines that I've pushed out to so far - with the exception of those 2 troublesome machines.

N.B:
I have also pushed the Citrix Drive mapper to these machines and have a GPO forcing the settings for every user. The policy points to [mysubdomain].sharefile.com as well. That works great; even on the 2 machines of despair.
I'm not entirely sure if IE is used to authenticate drive mapper as well; and if it does, that just confounds me even further.
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
I think I'm getting somewhere.
On my computer, which had a working version of the plug-in - i signed out and tried to sign in again.
when i did... bam.  Browser out of date.

Fiddled around with the registry.  Changed the method to 'standard'.  I get a log in screen.  But that log in screen isn't for our subdomain.  Its for secure.sharefile.com.
If i click the link below 'sign in with your windows credentials' - it goes straight to the Browser out of date link.
Photo of Leo

Leo, Official Rep

  • 382 Posts
  • 25 Reply Likes
Hey Renato,

The secure.sharefile.com question is because all our tools authenticate that way, so I was curious if manually doing that on a problematic machine gives similar results.  However, if you're using SSO then have you tried with different users on the two problem machines?  Just trying to make sure it's really the machines and not the users.

Edit: Just saw your update.  OK, so the SSO part is causing the Browser out of date message.  I'm checking up on that.

-Leo
(Edited)
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
wow. thank you so much.
Photo of Leo

Leo, Official Rep

  • 382 Posts
  • 25 Reply Likes
All right, all I was able to immediately locate was that when it happened before to someone, it was a micro-vpn issue.  I'm not sure if that's really enough for you to go by.
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
that doesn't help much.  Should I be calling support?
Photo of Leo

Leo, Official Rep

  • 382 Posts
  • 25 Reply Likes
Hey Renato,

Apologies for the delay in response.  Calling in to support would at least give account particulars, but support is using the same resources I am.  Other details I were able to find in the interim were:

- When it happened to someone before, it was because of a micro-VPN in use, and involved sending something back to ShareFile but not using a standard browser identifier.  

- If you have a legacy version of IE in your setup somewhere, that is a probable cause of triggering as well.  (But I'm assuming you've already ripped everything apart for this scenario.)

-Leo
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
We definately dont have any legacy versions of IE installed.  I don't even think win10 has any legacy installs.
I have other installs from sharefile on my system that log in using SSO as well - the desktop app and the drive mapper.  Those are working.  Do they use the same method of logging in?
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
Im running wireshark to see what is different between me doing SSO on sharefile desktop and sharefile for outlook.

The major difference are these Encrypted Alerts
TLSv1.2 Record Layer: Encrypted Alert
Content Type: Alert (21)
Version: TLS 1.2 (0x0303)
Length: 26
Alert Message: Encrypted Alert
These show up after a hello and handshake goes through
Photo of Kevin Glenn

Kevin Glenn, Senior Technical Support Engineer

  • 136 Posts
  • 12 Reply Likes
Hi Renato,

It would be great if we could schedule a time to discuss this situation further over the phone and perform a screen sharing session with an affected machine. Our development team is interested in investigating your environment to see what we can find. I left you a voicemail with my number, or if you prefer, you can reach me by email at kevin.glenn@citrix.com.

I look forward to speaking with you and helping to investigate.

-Kevin Glenn
Photo of Renato Dattilo

Renato Dattilo

  • 30 Posts
  • 6 Reply Likes
For posterity:
This was the fix that solved my woes:
HKCU:\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

add in a DWORD with the name "OUTLOOK.exe" and a value of 0x2af8
if this key already exists, change it.

this answer closely resembles Sebastian's in this post.  Location is just different.

if you're running a script for a bunch of users:

$outlookpath = 'HKCU:\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION'
function Test-OutlookReg {
    try {
        Get-ItemProperty -Path $outlookpath | Select-Object -ExpandProperty "OUTLOOK.exe" -ErrorAction Stop | Out-Null
        return $true
        }
    catch {
        return $false
        }
}

if (Test-OutlookReg -eq $true) {
    Set-ItemProperty -Path $outlookpath -Name "OUTLOOK.exe" -Value 0x2af8 -Force
    }
else {
    New-ItemProperty -Path $outlookpath -Name "OUTLOOK.exe" -Value 0x2af8 -PropertyType "DWORD"
    }
(Edited)
Photo of Alessandro Miotto Marques

Alessandro Miotto Marques

  • 7 Posts
  • 0 Reply Likes
Hello everyone,
I'm seen this issue on an Win7 with Chrome updated as a DEFAULT browser configured and an out-of-date IE version installed. I set the OUTLOOK key but it not solved my issue.

I'm configuring Sharefile Sync and we don't have Sharefile for Outlook plugin installed.

Anyone solved this?
(Edited)
Photo of Leo

Leo, Official Rep

  • 382 Posts
  • 25 Reply Likes
Hi Alessandro,

The authentication used by the tools goes through IE and cannot be changed, so if you actually do have an out-of-date version of IE installed then it would be expected for this to come up every time.  Please update.  

-Leo
Photo of Kent Soderlund

Kent Soderlund

  • 6 Posts
  • 1 Reply Like
Hello! 
Have the same problem:
  • Windows 10
  • Windows Update up to date
  • Can login with Citrix Files (Drive mapper)
  • Can login with Citrix Files sync
  • Can login to website through Chrome and IE
  • SSO works when I ́m in drive mapper choose "open website" with both Chrome and IE
  • Have set all the registry settings above
  • As soon I have entered my domain in the Outlook plugin: "Your broiwser is out of date"

Please assist!

UPDATE: As soon I restart Outlook the HKCU settin gs is changed from 2af8 to 2711

/Kent
(Edited)
Photo of Leo

Leo, Official Rep

  • 382 Posts
  • 25 Reply Likes
Hi Kent,

We've updated the article with the newly discovered information, but it takes some time for the server to update.  However, there are TWO paths involved.  One with "Policies" and one without.  The one without Policies will get overwritten, but people are finding that the one with "Policies" will work fine.

-Leo 
Photo of Kent Soderlund

Kent Soderlund

  • 6 Posts
  • 1 Reply Like
SORRY Leo! Missed that small word "Policies"  :)
Yep - that works - but as stated "Outlook today" gets blank - no problem for me, never use it

Thanks / Kent

The you can close my support case as well
Photo of Nathan Biden

Nathan Biden

  • 3 Posts
  • 1 Reply Like
I can confirm creating the path manually and adding the key. I'm now able to login into the outlook plugin. Thanks for the help guys. Hopefully one day we can remove the need to use IE from this.
Photo of Kevin Glenn

Kevin Glenn, Senior Technical Support Engineer

  • 136 Posts
  • 12 Reply Likes
Thank you for testing and confirming. You both rock!
Photo of Kevin Glenn

Kevin Glenn, Senior Technical Support Engineer

  • 136 Posts
  • 12 Reply Likes
Thank you for testing and confirming. You both rock!
Photo of Kevin Glenn

Kevin Glenn, Senior Technical Support Engineer

  • 136 Posts
  • 12 Reply Likes
For posterity / UPDATE: Due to recent changes in Outlook, we have updated our documentation for this issue and recommend modifying the below registry value for Outlook version 1808 10730.20102 or later.

Registry path: HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

If you could please add in a DWORD with the name "OUTLOOK.exe" and a value of 0x2af8

Or if this key already exists, modify it to 0x2af8

Please see https://support.citrix.com/article/CTX232021