Debug mode enabled

  • 1
  • Question
  • Updated 6 days ago
We have integrated our app via API. However, system is not working stable. Something we have developed and tested, working for some time and after some time it's not working. While checking via console we have found that debug mode is enabled. So we have doubt that there's some maintenance in the service? If not why debug mode enabled in production service? I need clarification on this.

Thanks in advance.
Photo of smart web

smart web

  • 4 Posts
  • 1 Reply Like
  • confused

Posted 2 weeks ago

  • 1
Photo of Senthilkumar

Senthilkumar

  • 4 Posts
  • 0 Reply Likes
Hello Smart Web,
I am also getting 500 error code When i call sharefile api file upload. This error is random. Some time i get while i upload 15 files, some time 60 files. 
Below is the error long. Kindly let me know are you facing same issue?

   "error":true,
   "errorMessage":"Unable to find credentials\r\n\r\nException 1 of 4:\r\nSystem.InvalidOperationException: The app.config/web.config files for the application did not contain credential information\r\n   at Amazon.Runtime.AppConfigAWSCredentials..ctor()\r\n   
at Amazon.Runtime.FallbackCredentialsFactory.<>c.<Reset>b__9_0()\r\n  
 at Amazon.Runtime.FallbackCredentialsFactory.GetCredentials(Boolean fallbackToAnonymous)\r\n\r\n
Exception 2 of 4:\r\nAmazon.Runtime.AmazonClientException: Unable to find the 'default' profile in CredentialProfileStoreChain.\r\n   
at Amazon.Runtime.FallbackCredentialsFactory.GetAWSCredentials(ICredentialProfileSource source)\r\n   
at Amazon.Runtime.FallbackCredentialsFactory.<>c.<Reset>b__9_1()\r\n  
at Amazon.Runtime.FallbackCredentialsFactory.GetCredentials(Boolean fallbackToAnonymous)\r\n\r\n
Exception 3 of 4:\r\nSystem.InvalidOperationException: The environment variables AWS_ACCESS_KEY_ID/AWS_SECRET_ACCESS_KEY/AWS_SESSION_TOKEN were not set with AWS credentials.\r\n   
at Amazon.Runtime.EnvironmentVariablesAWSCredentials.FetchCredentials()\r\n   at Amazon.Runtime.EnvironmentVariablesAWSCredentials..ctor()\r\n   at Amazon.Runtime.FallbackCredentialsFactory.<>c.<Reset>b__9_2()\r\n   
at Amazon.Runtime.FallbackCredentialsFactory.GetCredentials(Boolean fallbackToAnonymous)\r\n\r\nException 4 of 4:\r\nAmazon.Runtime.AmazonServiceException: Unable to reach credentials server\r\n   at Amazon.Runtime.URIBasedRefreshingCredentialHelper.GetContents(Uri uri)\r\n   
at Amazon.Runtime.InstanceProfileAWSCredentials.<GetAvailableRoles>d__10.MoveNext()\r\n   at Amazon.Runtime.InstanceProfileAWSCredentials.GetFirstRole()\r\n   at Amazon.Runtime.FallbackCredentialsFactory.ECSEC2CredentialsWrapper()\r\n   at Amazon.Runtime.FallbackCredentialsFactory.GetCredentials(Boolean fallbackToAnonymous)\r\n\r\n",
   "errorCode":500
}
Photo of smart web

smart web

  • 4 Posts
  • 1 Reply Like
Hi Senthilkumar,

I am not getting 500 error, Our problem is quite different, In random times we are not getting a response from shareFile API. While checking the problem we found that debug mode is enabled and we thought that is maybe the reason for instability.
That is why I want some clarification from API developer team. I hope we can get some clarification soon.

It has been more than a week and we are stuck on this issue.