Not receiving email with sign link when testing for one off document

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
Hello,

I have a test account with API keys to send pdf file to client for signature. I am following one off document workflows as described in API documentation.

All steps seem working.

1. PDF file created with text tag
2. POST sending request
3. PUT upload_url to upload the pdf file
4. Trigger upload file to process

According to workflows in step 5 Right Signature should deliver document with signing link to designated email.

But unfortunately I am not receiving any email. The email I used is completely different and not used in account OR login to account.

When I am checking file status it keeps showing:

{
"id":"cfa63cfe-bd2e-46c5-879d-04c86abbc092",
"status":"downloading",
"status_message":"File downloading",
"document_template_id":"0e816056-1311-4f0f-8fa2-d1c00b8108ba",
"created_at":"2018-04-03T06:52:59.723-07:00",
"updated_at":"2018-04-03T06:53:00.232-07:00"
}  
It seems the file is send and downloaded successfully. But after that nothing happening. File Status remains 'Processing'. So really wondering what goes wrong. It would be great if anyone could help me out with the issue.

Thanks and Regards

Shahin
Photo of Shahin Ahmed

Shahin Ahmed

  • 16 Posts
  • 1 Reply Like
  • confused

Posted 4 months ago

  • 1
Photo of Narayan

Narayan

  • 1 Post
  • 0 Reply Likes
@RSSupport - I am seeing the same issue at my end. The file is stuck on 'Processing' status. Any chance you could look into this issue?
Photo of Shahin Ahmed

Shahin Ahmed

  • 16 Posts
  • 1 Reply Like
Hello Narayan,

Sorry for late response. Please see my another post for solution still if you've the same problem.

"When GET to return data of document by document_template_id, recipients[ ] shows blank"

Hope it'll help. Thanks