outlook sharefile addin not working

  • 4
  • Problem
  • Updated 2 months ago
  • Solved
I have installed sharefile outlook plugin onto my computer. It installs correctly but when I try to run it, it prompts me for my username and password. I put these in but then get the message "there was a problem connecting to sharefile. Please verify that you are connected to the internet or contact sharefile support if the problem persists". I am using a windows 7 PC, I have tried on both outlook 2010 and outlook 2013. The plugin version is 3.1.

Another question are you able to share directly from the sharefile web interface or do you have to install either the desktop widget or outlook plugin.

Photo of Marek Tomecki

Marek Tomecki

  • 6 Posts
  • 1 Reply Like

Posted 5 years ago

  • 4
Photo of Ashlee Burch

Ashlee Burch

  • 676 Posts
  • 32 Reply Likes
Hi Marek,

Can you make sure that you are an 'Employee' user on the ShareFile account? This will affect you being able to use the Plugin. Also, you can share from both of the tools mentioned and you do not have to use the web application exclusively.

Please let me know if this helps, or if we need to troubleshoot further.
Photo of Justin Smith

Justin Smith

  • 5 Posts
  • 0 Reply Likes
I have the same issue. My user can use the website and the Sharefile Windows Sync with no problems. However when they try to login to the Outlook app they get this "there was a problem connecting to sharefile. Please verify that you are connected to the internet or contact sharefile support if the problem persists" I have reinstalled the plugin but receive the same error.  Any ideas? Is Louis answer legit?
Photo of Chris Anderson

Chris Anderson, Product Manager

  • 334 Posts
  • 53 Reply Likes
Depending on how the plugin was installed you may need to update a registry key to point APiCP to sf-api.eu: http://support.citrixonline.com/en_US/sharefile/help_files/SF020001?title=ShareFile+Plugin+for+Micro...  If that doesn't solve your issue, it will be best to have you create a ticket with the logs for your Outlook Plug-in found at %appdata%\ShareFile\Outlook
Photo of Louis Göhl

Louis Göhl

  • 24 Posts
  • 5 Reply Likes
Hi Marek,

There is a bug in the ShareFile Outlook plugin which affects EU ShareFile customers only.
The SSO ShareFile API is missing a registry entry.

You need to:

1. Close Outlook
2. Remove C:\Users\%username%\AppData\Roaming\ShareFile\Outlook\config.cfg
3. Add the following registry entry:

Windows Registry Editor Version 5.00

4. Start Outlook and the ShareFile Outlook plugin wizard will pop-up
5. This time you will be able to authenticate and complete the wizard.


Hope this helps!

-Louis Göhl
Photo of Justin Smith

Justin Smith

  • 6 Posts
  • 0 Reply Likes
Louis, Where did you learn of the Sharefile Outlook plugin bug? I didn't see any indication that your work around fixed the issue but I am not against trying.  I have the same problem as Marek.  Sharefile works fine for user but the plugin does not.
Photo of Marek Tomecki

Marek Tomecki

  • 6 Posts
  • 1 Reply Like
Hi Justin, I'm not in the EU, I'm in New Zealand so thats not affecting me. My issue was actually because I changed the name of sharefile site.

I was using the outlook plugin then changed the name of my sharefile website and then, then I changed all settings in the sharefile plugin and thought that would be enough but something was corrupted. But a quick uninstall of the outlook plugin and a reinstall with the correct settings resolved the issue. Sorry I failed to mention that in my initial post its quite a critical piece of information.

Photo of Volkswind


  • 2 Posts
  • 0 Reply Likes
Sorry to bring that back online.
I'm having that issue since about 4 weeks out of nowhere.
I already followed the instructions above but also seems to have the problem, that for example sf-api.eu (or .com) cannot be resolved.
This error only appears on the terminalserver whilst on clients, which also cannot ping sf-api.eu can work just fine.

I then installed the newest version of "Plugin_all_Users_3.4.19.0" which seems to be the only version running on terminalservers but it is still working.
Any new ideas?
Photo of Lokitha

Lokitha, Knowledge Services Specialist

  • 12 Posts
  • 0 Reply Likes

Hi Folks!

If you are unable to send files using ShareFile Outlook plugin, first make sure that your password is working by logging into yourdomain.sharefile.com.

For further instructions and more recommendations, refer to CTX223587 - ShareFile Outlook Plugin - Unable to Attach or Send Files, Icon Grayed Out

You might also want to check out our updated password requirements policy too: CTX240122 - Latest ShareFile Password Reset Frequency, Requirements and Policy