Users complaining about the Upload Location setting unknowingly reverting to File Box without notification.

  • 1
  • Problem
  • Updated 4 days ago
The setting found in Citrix Files for Outlook > Options > Requesting Files > Upload Location, seems to revert to the File Box, maybe with every update? I'm not sure when. 

(..for the developers, the install logs do show some clues of a Error migrating settings from the config file, [settingsprovider] key='ShareFileSettings.RequestTargetFolderId'.)

I understand that by default, uploaded files will be stored in the user's File Box, but they shouldn't have to reapply their choice for this setting every time an update installs. Many won't even know their choice was overridden.

Our users rely on their configuration persisting because we always configure the uploads destination to be one of their folders that is 'synced' to their local machine (via Citrix Files for Windows).

Right now, the only way to check whether the setting was reverted to the File Box is to go around to their workstations and check one by one. There is also no notification that this setting was changed so the user doesn't realize their configuration changed.

As far as I know, there is no way to verify or modify the Target Folder in either the Registry, an administrative install option, or even through the API. (I've checked them all --  Maybe the option is in the .cfg file, but it's encrypted so I can't check.) 

Can you provide instructions for reviewing this setting that doesn't include manually looking at it every time a user wants uses the "Request Files" button? 
Photo of Christopher Akina

Christopher Akina

  • 5 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Douglas Goodman

Douglas Goodman, Sr. Software Engineer

  • 93 Posts
  • 28 Reply Likes
Hi Christopher - Sorry to hear you're having problems with Citrix Files for Outlook.
Can you please make sure you're running the latest version of CFO? (6.2) We've had some issues in the past with the add-in not loading the settings file correctly and this forcing the user to login again with the side effect of losing the current settings. We made some improvements to address this in 6.2.

Thanks,
Doug
Photo of Claudio Ammann

Claudio Ammann

  • 22 Posts
  • 1 Reply Like
Hi, we are experiencing the same issue. Citrix Files for Outlook v6.2.10.0 looses its settings every other day. Users have to log in on Outlook start and find their settings reset. What is wrong?

Thanks for any help

Claudio
Photo of Douglas Goodman

Douglas Goodman, Sr. Software Engineer

  • 93 Posts
  • 28 Reply Likes
Hi Caludio - Can you please provide a log file displaying this behavior? I'd like to investigate this further.

The log file (log.txt) can be found in this folder: %appdata%\Citrix\Citrix Files for Outlook

Please upload it here using this link: https://citrix.sharefile.com/r-r68e92d9dd794bacb

Thanks,
Doug

Photo of Claudio Ammann

Claudio Ammann

  • 21 Posts
  • 1 Reply Like
Hi Doug, done that. Last occourance was yesterday. Thanks Claudio
Photo of Douglas Goodman

Douglas Goodman, Sr. Software Engineer

  • 93 Posts
  • 28 Reply Likes
Hi Claudio - Thanks for sending that log file. We've implemented an improvement that should fix this error. It will be included in the next release, 6.3, which should be available in January 2019.

Thanks,
Doug
Photo of Claudio Ammann

Claudio Ammann

  • 21 Posts
  • 1 Reply Like
OK, thanks. Citrix ShareFile continues to share bugs unfortunately.

Please post an update in here when the fix is released.
Photo of Andy S

Andy S

  • 6 Posts
  • 2 Reply Likes
Douglas,

Any update to this? I keep having to change the Upload Location and it does not stick between emails.  How do we get this to persist?  ETA on next version to fix this version?
Photo of Douglas Goodman

Douglas Goodman, Sr. Software Engineer

  • 93 Posts
  • 28 Reply Likes
Hi Andy - Are you setting the default upload location? Or just the per-message value? The default is set via the Options button in the main Outlook ribbon.

Our next release will have an update that should address the issue of settings being lost. We are addressing a few last minute blockers, but this should be released soon. Thanks for your patience.
Photo of Andy S

Andy S

  • 6 Posts
  • 2 Reply Likes
Hi Douglas,

I'm setting it in the ShareFile "Options" outside of a new message, but when going into a new email, it's reverting back to "File Box".
Photo of Douglas Goodman

Douglas Goodman, Sr. Software Engineer

  • 93 Posts
  • 28 Reply Likes
Are you restarting Outlook in between?
Photo of Andy S

Andy S

  • 6 Posts
  • 2 Reply Likes
I've tried that too but doesn't stick
Photo of Douglas Goodman

Douglas Goodman, Sr. Software Engineer

  • 93 Posts
  • 28 Reply Likes
No, I mean there is a bug that may reset the value IF you restart Outlook after setting your folder.

Is the add-in requiring you to sign in every time you start Outlook?
Photo of Andy S

Andy S

  • 6 Posts
  • 2 Reply Likes
Gotcha.

I did see the bug before, but was running an older version that seemed to have fixed that login issue in the current 6.2 version I'm running, that's for me anyways.
Photo of Claudio Ammann

Claudio Ammann

  • 22 Posts
  • 1 Reply Like
Any update on the release of the plugin?

Thanks

Claudio
Photo of Anthony Price

Anthony Price, Quality Engineer / Release Manager

  • 107 Posts
  • 17 Reply Likes
Hi Claudio, 

We are hoping to have the next release of the Outlook Plug-in out by next week. 

Thanks!
Photo of Claudio Ammann

Claudio Ammann

  • 22 Posts
  • 1 Reply Like
There isn't anything new out is it? Can we agree that you drop a note as soon as there is something out? Or can I subscribe somewhere?

Best regards

Claudio